IJKs E63 645Ci - BMW-Driver.net Forums
BMW-Driver.net Forums  

Go Back   BMW-Driver.net Forums > General Motoring Discussion > The Showroom > Members Cars & Gallery
User Name
Password
Register FAQ Calendar Mark Forums Read Advertise Auto Loans

Members Cars & Gallery Photos and specs of your cars.


Reply
 
Thread Tools Display Modes
  #1  
Old 25-Feb-2015, 07:14 PM
zippyijk zippyijk is offline
Junior Member
BMW Driver
 
Join Date: Jul 2010
Posts: 48
Thanks: 13
Thanked 8 Times in 5 Posts
Default IJKs E63 645Ci

Hi All,
Got myself an E63 645Ci with the N62B44 engine.
Wanted a V8 before the petrol disappears

Here's some pics









Reply With Quote Quick reply to this message
The Following 3 Users Say Thank You to zippyijk For This Useful Post:
georgian (24-Mar-2015), kceire (25-Feb-2015), Mackers (25-Feb-2015)
Sponsored Links
Advertisement
 
  #2  
Old 25-Feb-2015, 07:34 PM
zippyijk zippyijk is offline
Junior Member
BMW Driver
 
Join Date: Jul 2010
Posts: 48
Thanks: 13
Thanked 8 Times in 5 Posts
Default

Today I did some coding. Took a while to get to grips with the NCS Expert etc. after coming from the ease of VCDS for the last few cars.

Here's what I changed,
CANS:
QUIT_OPT_SCHAERF (Optical flash on exit/lock)
aktiv
QUIT_AKUST_SCHAERF (Alarm bleep on exit/lock)
aktiv


CAS:
QUIT_OPT_SCHAERF (Optical flash on exit/lock)
aktiv
QUIT_AKUST_SCHAERF (Alarm bleep on exit/lock)
aktiv
VIDEO_DENY (Video in Motion) - Not working see below
deny_never
BC_DIGITAL_V (Digital speed display)
aktiv
HEIMLEUCHTEN_FUNKSCHL (Welcome home lights on by remote locking)
aktiv
HEIMLEUCHTEN_NSW (Welcome home lights with front fog lights
aktiv
QUIT_OPT_SCHAERF (Optical flash on exit/lock)
aktiv
HEIMLEUCHTEN_ABBRUCH (Coming home lights....can't remember exactly which)
aktiv
QUIT_AKUST_SCHAERF (Alarm bleep on exit/lock)
aktiv


COMBI:
BC_DIGITAL_V (Digital speed display)
aktiv

LMA:
HEIMLEUCHTEN_FUNKSCHL (Welcome home lights on by remote locking)
aktiv

SHD:
REGENSCHLIESSEN (Enabled both for Rain sensor to close sunroof)
aktiv
REGENSCHLIESSENTILT
aktiv


Thanks very much to RebelRanters posts here and elsewhere for an initial idea on what I needed to get set up

I'm still not getting the Video in motion working. Not sure what else I need to change yet. Any ideas?

I also want to change my analog tuner module to a digital one, if anyone sees one up for sale let me know.

Lastly for now does anyone know if it's possible to retrofit the HUD?
Reply With Quote Quick reply to this message
  #3  
Old 25-Feb-2015, 08:17 PM
BavarianCare BavarianCare is offline
Senior Member
BMW Driver
 
Join Date: Dec 2012
Posts: 538
Thanks: 73
Thanked 205 Times in 154 Posts
Default

VIM is one 'job' with Autologic.
You need to code CCC-A as well


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
 
  #4  
Old 25-Feb-2015, 11:35 PM
rebel.ranter rebel.ranter is offline
Senior Member
Silver Member
 
Join Date: Sep 2008
Location: Cork
Posts: 4,001
Thanks: 1,261
Thanked 2,865 Times in 1,576 Posts
Default

The enable video in motion in the CAPPL change the following:

VIDEO_DENY
deny_stop_break

To
VIDEO_DENY
deny_never

Also in CAPPL in order to add the acoustic chirp options in the iDrive menu, change ACOUSTIC from nicht_aktiv to aktiv.
__________________
1996 320iC /2002 525iA Sport /2006 630i SMG Sport
Reply With Quote Quick reply to this message
Thanks From:
zippyijk (25-Feb-2015)
  #5  
Old 26-Feb-2015, 10:56 AM
zippyijk zippyijk is offline
Junior Member
BMW Driver
 
Join Date: Jul 2010
Posts: 48
Thanks: 13
Thanked 8 Times in 5 Posts
Default

Quote:
Originally Posted by rebel.ranter View Post
The enable video in motion in the CAPPL change the following:

VIDEO_DENY
deny_stop_break

To
VIDEO_DENY
deny_never

Also in CAPPL in order to add the acoustic chirp options in the iDrive menu, change ACOUSTIC from nicht_aktiv to aktiv.
Ah couldn't access the CAPPL module and one or two others, getting a COAPI-2041: Wrong ECU coding index error......
Just updated the DATEN files and it's all good.

Will change the VIDEO_DENY on it later.

Any other good changes I could make?
Is there such a thing as needle sweep (staging) on BMWs like on the VAG cars?
Reply With Quote Quick reply to this message
  #6  
Old 26-Feb-2015, 11:14 PM
rebel.ranter rebel.ranter is offline
Senior Member
Silver Member
 
Join Date: Sep 2008
Location: Cork
Posts: 4,001
Thanks: 1,261
Thanked 2,865 Times in 1,576 Posts
Default

Quote:
Originally Posted by zippyijk View Post
Ah couldn't access the CAPPL module and one or two others, getting a COAPI-2041: Wrong ECU coding index error......
Just updated the DATEN files and it's all good.

Will change the VIDEO_DENY on it later.

Any other good changes I could make?
Is there such a thing as needle sweep (staging) on BMWs like on the VAG cars?
It sounds like your DATEN Files are too old for your car. The needle sweep is possible but not with coding. There is a module that I read about that will do this.
__________________
1996 320iC /2002 525iA Sport /2006 630i SMG Sport
Reply With Quote Quick reply to this message
  #7  
Old 03-Mar-2015, 09:27 PM
zippyijk zippyijk is offline
Junior Member
BMW Driver
 
Join Date: Jul 2010
Posts: 48
Thanks: 13
Thanked 8 Times in 5 Posts
Default

So about time to get rid of all these yellow lights
Ordered LEDs for Angel Eyes, White H7 for high beam, White for fogs, Interior LED pack, White LEDs for number plate. All should be error free.
Will do before & after pics!

Ordered up a new bonnet badge, current one has a stone chip and it's annoying me.

Lastly ordered 2 parking sensors 1 for front and 1 for back with black sapphire pearl colour code. 1 back is gone and 1 front is intermittant. I believe they're a pox to replace, guess I'll see.

Have my eyes on a hybrid tuner to replace the now useless analog one. Not pulled the trigger on it yet, might wait a month or two.
Reply With Quote Quick reply to this message
  #8  
Old 23-Mar-2015, 08:19 PM
zippyijk zippyijk is offline
Junior Member
BMW Driver
 
Join Date: Jul 2010
Posts: 48
Thanks: 13
Thanked 8 Times in 5 Posts
Default

So I've done a load of little things on the car in the last couple of weeks....

The badge had a nice stone chip in it and was annoying me to look at so an easy and cheap replacement.





Then while I'm waiting for all my new bulbs to arrive I decided to change the number plate lights. I had some Philips Bluevision LED 6000k that I had left over from my old car.

Here's the horrible oem yellow lights


But when I took them apart it turns out they're not festoon but w5w bulbs but at least I had a set of Philips Bluevision W5W that came free last time I was ordering stuff.



And here they are in, not much better but they'll do for now. And yes the car is manky, needs a wash!


I also enabled the video in motion for my CCC unit. As Rebel had said I had to enable it in the CAPPL and CAS modules with ncs expert. Turned on alarm chirp when locked too.

Loads more to do, I've an interior led pack on the way, all the bulbs as mentioned and then got a cheap obdii HUD to see how it looks. Original would cost over 2k to retrofit, far too much.
Reply With Quote Quick reply to this message
  #9  
Old 23-Mar-2015, 08:31 PM
zippyijk zippyijk is offline
Junior Member
BMW Driver
 
Join Date: Jul 2010
Posts: 48
Thanks: 13
Thanked 8 Times in 5 Posts
Default

Then got some more of the bulbs...
Philips Whitevision H7 & OSRAM Cool Blue Intense HB4

The High beams (H7) were easy enough to replace even with big hands!

The Fogs (HB4) were a pain the the ring! The passenger side is a nightmare with the washer fluid tank in the way from the wheel arch. Drivers side wasn't as bad, not much in the way.

I think the H7 are still too yellow in comparison to the xenons.
Fogs look better than stock.

Before:


Thou shalt not pass!....in the back you go!


From behind, rotate to remove


Changed
Reply With Quote Quick reply to this message
  #10  
Old 23-Mar-2015, 08:33 PM
zippyijk zippyijk is offline
Junior Member
BMW Driver
 
Join Date: Jul 2010
Posts: 48
Thanks: 13
Thanked 8 Times in 5 Posts
Default

Got some more bits in the post today.

Got 3 colour coded, sapphire black pearl, parking sensors from a breakers in Germany. Guaranteed as working. Need one for the rear and one of my fronts is intermittent depending on the weather. Got a spare obviously.

Also got my 10W LED angel eyes from benzinfabrik. I've used this crowd before. They build great led lights.


Also got a cheapo HUD from eBay. It's a Chinese made brand called ifound h101 HUD. Reviews are 50/50 on good v crap. We'll see.





Well literally a 5 min job to replace.






Replacing the parking sensor is going to be a pox. I can get my hand in under the bumper beside the exhaust and just get my fingers on it. I'll give it a proper shot over the weekend.
Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Smilies
Options

Register Now

In order to be able to post messages on the BMW-Driver.net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 07:47 PM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vB.Sponsors
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.