BMW-Driver.net Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Having a weird issue and hoping someone has either heard of it before or can give some advice?

My 2018 G30's instrument cluster has been acting weird. Mostly happens after returning to the car after it being driven (doesn't matter for how long or whatever), then IDrive wakes up but cluster is completely blank...

When I park the car up and lock it and return about an hour later it's back like nothing happened. Keeps happening though which isn't ideal if you want to know what speed you are doing or how much fuel is in the car :). I got the software updated before Christmas and that has not changed the problem. Everyone seems to scratch their head when they look at it and just say it has to be software but I have yet to have anyone actually fix it!

Any advice/help would be greatly appreciated!
 

·
Registered
Joined
·
2 Posts
hi ben.. how did you get sorted. I've a 2017 530e and its the same.. i'm irish too!! Was a new cluster the solution?kind regards justin
Following as I've got exactly the same problem. Software updated in January, problem came back in March. Apparently BMW Oxford are getting BMW UK involved as they haven't seen the issue before. Loathe to pay £2k for the instrument cluster alone, if that's the road they want to go down.
 

·
Registered
Joined
·
5 Posts
HI simon, i bought a 6wb cluster from Artur Dowmont BMW spares in Germany, he's on Ebay. He matched a low mileage cluster to my car. Having it 'virginized' (wiped) , and coded to my car next week! I'll let you know how i get on. Look out for a specialist car coder in your area in the meantime.
Its a common problem with the early g30, BMW recommend replacing. Hopefully, it'll be a €1k bill rather than the €4k one my BMW dealer quoted :)
 

·
Registered
Joined
·
2 Posts
HI simon, i bought a 6wb cluster from Artur Dowmont BMW spares in Germany, he's on Ebay. He matched a low mileage cluster to my car. Having it 'virginized' (wiped) , and coded to my car next week! I'll let you know how i get on. Look out for a specialist car coder in your area in the meantime.
Its a common problem with the early g30, BMW recommend replacing. Hopefully, it'll be a €1k bill rather than the €4k one my BMW dealer quoted :)
Have you had the cluster installed yet Jucko? If not keep me posted when you do! Did you actually get BMW to diagnose the problem before you went down the road of sourcing one on ebay?
 

·
Registered
Joined
·
5 Posts
yes, went to main dealer, they tried to reprogram, failed and recommended replace cluster... €4000. Hopefully my 'new' cluster arriving today. the battery is also draining as a result, hopefully itll all be sorted
 

·
Registered
Joined
·
2 Posts
Guys just to share similar experience with a audi a6 cluster exactly same situation and i ended up spending thousands of euros in audi north dublin diagnostic around 9k and in the end it was the ecu module causing the issue not cluster or wiring i thought this might be helpful
 

·
Registered
Joined
·
1 Posts
HI simon, i bought a 6wb cluster from Artur Dowmont BMW spares in Germany, he's on Ebay. He matched a low mileage cluster to my car. Having it 'virginized' (wiped) , and coded to my car next week! I'll let you know how i get on. Look out for a specialist car coder in your area in the meantime.
Its a common problem with the early g30, BMW recommend replacing. Hopefully, it'll be a €1k bill rather than the €4k one my BMW dealer quoted :)
How did ur instrument cluster work out having the same problems. 2600 for new one not includeding programing. Thinking of going down the same road as u.
 
1 - 11 of 11 Posts
Top