BMW-Driver.net Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi Folks,

Looking for opinions on a BMW E46 320D.
Some months back, it began to plume black smoke quite heavily from the exhaust, when accelerating at startup.
It also looses a severe amount of power goes in to limp mode. If driving off on a hill it can be an embarrasement.... plumes of black smoke everyhwre and a Beemer going nowhere fast! The diesel economy has also decreased dramatically since this issue started!!

Anyway, I've tried a number of things but still no joy in sourcing the problem.

The EGR valve has been cleaned and whilst it's dirty, it's not in too bad condition.

I then decided to have my cousin (who's a mechanic) take a quick look at it. He reckons the EGR vavle is probably caked and it's possibly causing the turbo on it to seize/engage.
He also removed the airflow meter, which has allowed it to drive a lot better but now it sounds something like a screaming ewok anytime the accelerator is pressed!! + it's still smokey as hell and not much more power.

Since then We've noticed a big crack on the inlet mainfold, again believing this might be the culprit, we stuck in a replacement manifold (with flaps removed) but again, no joy!!
His diagnostocs are picking up faults but are not singling out anything in particular.

Having read other forums, I've also heard and been advised everything from:
- try an EGR bypass
- boost leak
- faulty injectors
- crankcase breather
- split inlet pipe
- pressure converter filters
- replace vacuam hoses

getting the injectots tested may be the next course of action, but again this is a stab in the dark!

Would appreciate any opinions on this. It has to be a common enough problem with BMW320Ds?
 

·
Registered
Joined
·
6,506 Posts
Sounds like a boost sensor, command etc or a boost leak either boost hose/pipe or exhaust either after or before ie exhaust mani or cat etc, limp mode when driving, if you turn car on and off while still moving does boost come back ? And does it only happen say on low revs been under pressure. ? say in 5 th and come to a slight hill with slight throttle input ?
 

·
Registered
Joined
·
1 Posts
Hi Folks,

Looking for opinions on a BMW E46 320D.
Some months back, it began to plume black smoke quite heavily from the exhaust, when accelerating at startup.
It also looses a severe amount of power goes in to limp mode. If driving off on a hill it can be an embarrasement.... plumes of black smoke everyhwre and a Beemer going nowhere fast! The diesel economy has also decreased dramatically since this issue started!!

Anyway, I've tried a number of things but still no joy in sourcing the problem.

The EGR valve has been cleaned and whilst it's dirty, it's not in too bad condition.

I then decided to have my cousin (who's a mechanic) take a quick look at it. He reckons the EGR vavle is probably caked and it's possibly causing the turbo on it to seize/engage.
He also removed the airflow meter, which has allowed it to drive a lot better but now it sounds something like a screaming ewok anytime the accelerator is pressed!! + it's still smokey as hell and not much more power.

Since then We've noticed a big crack on the inlet mainfold, again believing this might be the culprit, we stuck in a replacement manifold (with flaps removed) but again, no joy!!
His diagnostocs are picking up faults but are not singling out anything in particular.

Having read other forums, I've also heard and been advised everything from:
  • try an EGR bypass
  • boost leak
  • faulty injectors
  • crankcase breather
  • split inlet pipe
  • pressure converter filters
  • replace vacuam hoses

getting the injectots tested may be the next course of action, but again this is a stab in the dark!

Would appreciate any opinions on this. It has to be a common enough problem with BMW320Ds?
Hi I’ve got the same problem have you found out what it is?
 
1 - 3 of 3 Posts
Top