BMW-Driver.net Forums banner
41 - 60 of 75 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #41 ·
UPDATE!!!!

I tried to read a mate's E60 (08 also) and I'm getting the same error.... This leads me to believe that it is a software/setting issue.
I was kinda hoping it would be the same because now I'm quite sure the Dension is connected properly and the fibre optic loop is ok.......

Soooo, any more ideas guys???????

Ken
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #42 ·
Finally, I get to read the MASK module.......I loaded Revtor's profile and when I get the ''enter SGET data'' pop up I had to change the CABD name field to: A_E65MMC.IPO hit ok and it read the MASK... :D
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #43 ·
Even though I can read the MASK module now it is showing CDC - Aktiv & MP3 - Aktiv. However when I check IDrive hidden menu CDC is False & MP3 is True. Others have suspected that the Trace file may not be correctly reading module???
The front load CD player does play MP3's so my guess is that the CDC will also if I can activate it to work through IDrive.

I changed CDC value to nicht_Aktiv and back to Aktiv but still does not work...

I'm all out of ideas right now and cannot find any solution on-line... I guess its time to put the hands up and get it programmed with autologic.......

Anybody have any thoughts before the white flag??????????

Ken:confused:
 

·
Registered
Joined
·
4,427 Posts
Here's some shots of the dip switch settings on my Dension (e63, but same as e60):



Here's a video showing the sound from the Radio (not Dension) being interrupted when the fibre optic connection is unplugged & then re-plugged back in.


Here's a photo just confirming which side the fibre optic cable plugs in to. Note the Dension unit is upside down:

 

·
Registered
Joined
·
38 Posts
Discussion Starter · #46 ·
I have the connections the same only thing is that when I break the continuity the radio/cd plays as normal.

I notice you have no 6 DIP switch off which is contrary to the Dension instructions...... but it works... So i will try this later.

I read somewhere earlier to remove $672 and try +IPOD

Something I havent been doing is powering off the dension after making any change to let unit reset. Sooooo ill have a go at lunch time..

Not quite done yet Colm Ha.......:)


I cant believe you stripped the dash already Rebel........ insane......
 

·
Registered
Joined
·
4,427 Posts
As I said, I'm convinced that the coding is right, the CD changer is showing up in DIS & it wouldn't if it was not already coded.
My next move would be:
1: Try reversing the fibres
2. If no joy then try to do what I did wiith the fibres directly at the back of the head unit.
 

·
Registered
Joined
·
4,427 Posts

·
Registered
Joined
·
4,427 Posts
I had issues with coding using that particular cable, it was hit & miss. I had no issues updating the VO though. It was perfect for diagnostics though. I've since moved on to the BMTechnics one & also the ADS:OBD one for older cars.
 

·
Registered
Joined
·
4,427 Posts
what do you mean? so will try to code the CAPPL on weekend with that black adapter. Do i understand it correct, that CAPPL is for idrive professional and MASK module has cars with idrive bussines?
CAPPL is professional Nav, Mask is (small screen) business Nav or no Nav.
I meant that I have now abandoned that interface in favour of the one supplied by BMTechic.
 

·
Registered
Joined
·
4,427 Posts
Ah right, it is the CCC_APP module that you need to modify. I have attached an export from NCS Dummy that shows you all the parameters in this module along with English descriptions & the various permissable settings for these parameters.

The two main ones:

Parameter: MP3_CCC
Setting: full

Parameter: CDC
Setting: aktiv

Add +IPOD to the VO for both CAS & LMA, make sure you are using the ExpertMode profile & use the "FA_WRITE" job. Any errors you get when doing the VO modify or coding change mean that the coding will not go through. If you get an error & then try again & the coding seems to go through it actually has not. I would disconnect the battery for 20 minutes after coding. The CCC doesn't like being coded, some of the DIYs that I have read suggest that you need to turn off the car for a few moments (then switch back to position 2) before you code the CCC. In fact I would disconnect the battery for 20 minutes before you start coding again.

That is exactly how my CCC is set up, my car had a MASK up to a week ago, I upgraded to a CCC then to get satellite navigation. So I've seen the difference between CCC & MASK.
 

Attachments

·
Registered
Joined
·
12 Posts
hi,

yeah I have already those atrributes set in CAPPL.

CDC
aktiv
MP3_CCC
full
VA_MP3_DISCLAIMER
aktiv

but question if i need to write somewhere the rest:

MP3
activ
MP3CDC
aktiv
MP3_CHAMP
aktiv
CDMM_CHANGER_3
mp3_cdc


So my last chance is to try add +IPOD to VA instead of +672

thanks
 

·
Registered
Joined
·
362 Posts
hi,

yeah I have already those atrributes set in CAPPL.

CDC
aktiv
MP3_CCC
full
VA_MP3_DISCLAIMER
aktiv

but question if i need to write somewhere the rest:

MP3
activ
MP3CDC
aktiv
MP3_CHAMP
aktiv
CDMM_CHANGER_3
mp3_cdc


So my last chance is to try add +IPOD to VA instead of +672

thanks
No such thing as a MP3_CHAMP entry in a CAPPL module, you would not even be able to code it without getting an error.

Do this, 3 easy steps.

- +IPOD in the VO (Update LM and CAS)
- +KMP3 in the VO (Update LM and CAS)
- Disconnect the negative plug of the battery, leave it for 5mn.

It should be working now, assuming your dip switches are ok and your connection to the radio is too.

No need to edit individual settings of the CAPPL module. In fact, it is wrong. Don't touch them. No need.

From from what you are typing, I strongly suspect this E60 does not have actually have an iDrive Professional, but rather a Business or Even M-ASK standard unit, otherwise you would have failed to code the module with MP3_CHAMP completely.

Or this iDrive was retrofitted and the VO never changed, reason why you only see MASK in the modules options.
 

·
Registered
Joined
·
12 Posts
. I have tried codes in VO +KMP3 +IPOD and also +KMP3 $672, but gain without any luck. The $694 code I have removed

But the Dension is finally light all the timw with blue LED , so communication is OK. I have checked the CAPPL and there is:
CDC
aktiv

MP3CCC
full

I can change the attributes for example to nicht_aktiv


but I cant add the rest , like:
MP3
activ
MP3CDC
aktiv

It still doesnt work. What am I missing? Do I have to code another module? Add some attributes? some FA?

the e60 has idrive professional, it has CCC module, and here is the origin VO:


Název (ETK)
S1CAA SELEKTION COP RELEVANTER FAHRZEUGE
S203A ALLRADSYSTEM
S205A AUTOMATIC GETRIEBE
S255A SPORT-LEDERLENKRAD
S300A NOTRAD
S354A GRUENKEIL-FRONTSCHEIBE
S430A INNEN-/AUSSENSPIEGEL AUT.ABBLENDEND
S431A INNENSPIEGEL,AUTOMATISCH ABBLENDEND
S438A EDELHOLZAUSFUEHRUNG
S441A RAUCHERPAKET
S502A SCHEINWERFER-WASCHANLAGE
S508A PARK DISTANCE CONTROL (PDC)
S522A XENON-LICHT
S524A ADAPTIVES KURVENLICHT
S534A KLIMAAUTOMATIK
S540A GESCHWINDIGKEITSREGELUNG
S563A LICHTPAKET
S589A LM RAEDER STERNSP.122 MIT NOTLAUF.
S609A NAVIGATIONSSYSTEM PROFESSIONAL
S694A CD-WECHSLER VORBEREITUNG
S698A AREA-CODE 2
S855A SPRACHVERSION ITALIENISCH
S863A SERVICE KONTAKT-FLYER EUROPA
S884A ITALIENISCH / BORDLITERATUR
S8SAA LAENDERSPEZ. NAVI.-FREISCHALTUNG
S8SPA COP STEUERUNG
S928A REIFENSTEUERUNG

Sériové vybavení

S216A SERVOTRONIC
S548A KILOMETERTACHO
S785A WEISSE BLINKLEUCHTEN
 

·
Registered
Joined
·
4,427 Posts
You should not have to change the paramters after doing the VO additions. "CDC aktiv" & "MP3 CCC full" are the only two settings that need to be made for CCC, the other two parameters are related to the more basic M-ASK system (no navigation). Did you disconnect the battery for 20 minutes after making the changes?

Try this next.
 

·
Registered
Joined
·
12 Posts
Hi again,
so this is our actual status:
Car is coded, battery was unplugged for 20 minutes, after that we got 4x4 error, but it dissappeared after few meters driven.
in VO is +KMP3 ,+IPOD
in CAPPL is "CDC aktiv" & "MP3 CCC full"

Dension blue LED is ON, but we cant still see it! when we choose CD in idrive menu, we get this error:






but if we put audio cd into CCC , it seems the car knows about the CD changer:


 
41 - 60 of 75 Posts
Top