BMW-Driver.net Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
78 Posts
E3/E4 Fuel trim bank 1/2 : permissible range exceeded

Hi guys,

Recently posted issues on a e46 320i, thanks to rebel ranter got some very useful diagnostic, but as I drove on this morning engine management light come up right next to 1 of the pit stop garage, 35 q for a red well better to know what is the light for we got the following error codes :(

  • E4 Fuel trim bank 2 : permissible range exceeded
  • E3 Fuel trim bank 1 : permissible range exceeded

Any 1 familiar with this code as they haven't got a clue what is going on

a car smell a bit sweetish as a catalytic Conv superheat, loads of fuel???

can I keep the sweet smell and remove the issue? :?)) well this is not my real question


cheers lads


ger
 

·
E28 M535i
Joined
·
1,858 Posts
its hard to tell what the codes mean as you dont mention what diagnostic software returned the codes. different diag softwares have differnet codes

however I reckon the codes relate to lean running. I would be checking for any air leaks or spit hoses under the bonnet. Any extra air and it will run lean, causing the fuel trim faults. Check for any split hoses as the fuel trim codes are relating to both banks of cylinders. If no split hoses I would be suspecting a faulty MAF

i would have the codes reset then drive the car for a couple of days and get the codes read again
 

·
Registered
Joined
·
78 Posts
Hi cheers for repl. i froget to relink the previous thread

it was some kind of delphi diagnostic tool, but probably this is a make, not a softver what they used:(

maf was changed so as a few bit:
getting very very tired of this issue :( ideas

previous thread
the car is running on 25mpg on normal granma driving style so if it leans I'm doomed :((
 

·
Site Sponsor
Joined
·
2,034 Posts
Check for airleaks as already mentioned. Check your CCV as well while you're at it.
If you took a proper oem brand MAF then that should rule this part out. If yopu used a spurious one then it could still be the MAF. Other then that my money is on the O2 sensors.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #5 ·
Update :

was in the garage today as my light come up again.
no specific reason again, the lad say the 2 o2 sensor has a deviation, they not shoving a same results....
is can make any diffeernt or should they show the same result?
also he mentioned there could be sum leaky injector...
how bad it could hurt?
she stil runing bad if i try to drive gently..ans 22mpg :((
also agani 1l oil after 400miles, and there is no sign of any leak even on the underbody, and no sign of smoke :(

cheers for ideas
ger
 

·
Registered
Joined
·
1,255 Posts
Sounds like it's running too rich and maybe washing fuel past rings which is diluting engine oil and causing it to thin out and then burn back past rings

If it's burning oil which it obviously is then it will show strange lambda readings
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #7 ·
Sounds like it's running too rich and maybe washing fuel past rings which is diluting engine oil and causing it to thin out and then burn back past rings

If it's burning oil which it obviously is then it will show strange lambda readings

any quotes what can cause to run rich? and that might right as the oil smells petrool waay too much
 

·
Site Sponsor
Joined
·
2,034 Posts
any quotes what can cause to run rich? and that might right as the oil smells petrool waay too much
Yeah O2 sensors when faulty cause this. So do airleaks etc.....Also if you take the plugs out you might be able to see if you have injector issues. A good diag should be able to read the duty cycle on them so you can check if the signal is ok.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top