BMW-Driver.net Forums banner

1 - 12 of 12 Posts

·
Bavaria Power!!!!!
Joined
·
566 Posts
Discussion Starter #1
Hey guys,
My E65 is after losing the plot today!!!:( I was driving to Dublin today and everything was fine on the way up but on the way down the car went nuts!!! While cruising at about 65mph on the motorway the car started to lose power and slow down for no apparant reason,as I pulled into the hard shoulder,I got a warning of "DSC failure,drive moderatly!" and as I stopped the revs were lunging wildly between tickover and 1500 rpm. I turned the car off and when I started it everything was good and I still had the DSC failure on the Idrive and the light on the dash. I kept driving and about another 40ish miles and it did the exact same thing again,loss of power and wonky revs as I stopped which was fine after I restarted it. I was thinking if the battery was down on voltage would this cause such mayhem with it?:confused: Any help is appreciated greatly as always!!!!!
 

·
Registered
Joined
·
4,001 Posts
I'm no expert but the electronics in an e65 can be sensitive to dodgy batteries. I even saw an e39 go nuts.
Then again your car could be doing the BMW equivalent of blue screening.
 

·
Bavaria Power!!!!!
Joined
·
566 Posts
Discussion Starter #3
I'm no expert but the electronics in an e65 can be sensitive to dodgy batteries. I even saw an e39 go nuts.
Then again your car could be doing the BMW equivalent of blue screening.
Blue-screening????????? What is that cos thats the first time i've heard of it.....
 

·
Doktor Displacement
Joined
·
4,738 Posts
Hey guys,
My E65 is after losing the plot today!!!:( I was driving to Dublin today and everything was fine on the way up but on the way down the car went nuts!!! While cruising at about 65mph on the motorway the car started to lose power and slow down for no apparant reason,as I pulled into the hard shoulder,I got a warning of "DSC failure,drive moderatly!" and as I stopped the revs were lunging wildly between tickover and 1500 rpm. I turned the car off and when I started it everything was good and I still had the DSC failure on the Idrive and the light on the dash. I kept driving and about another 40ish miles and it did the exact same thing again,loss of power and wonky revs as I stopped which was fine after I restarted it. I was thinking if the battery was down on voltage would this cause such mayhem with it?:confused: Any help is appreciated greatly as always!!!!!
I've said this to you before.

There is that many electronic systems on your car there could be so many things causing this problem.

You can check the charge on your battery with a multimeter.

However I will advise you again to just get the car connected up to a proper BMW diagnostics computer!

Have you not only owned this car for a couple of months? Why dont you bring it back to the dealer you bought it from?
 

·
Bavaria Power!!!!!
Joined
·
566 Posts
Discussion Starter #5
I've said this to you before.

There is that many electronic systems on your car there could be so many things causing this problem.

You can check the charge on your battery with a multimeter.

However I will advise you again to just get the car connected up to a proper BMW diagnostics computer!

Have you not only owned this car for a couple of months? Why dont you bring it back to the dealer you bought it from?
I will have to get a BMW diag done. In my infinite wisdom:) I decided I would save on the asking price and buy the 7er without a warranty to save a grand,wasn't that just the most amazing move!!!!! What figures am I looking for on the multi-meter and would I check it while running or shut-down?
 

·
Registered
Joined
·
4,001 Posts
Blue-screening????????? What is that cos thats the first time i've heard of it.....
If you have ever owned or used a Windows PC or laptop you will have experienced "blue screen". Normally it means a complete software rebuild fir the laptop. Hope it's not the case for your car.
 

·
You looking at me
Joined
·
492 Posts
Check voltage with engine off... your looking for 12v
with engine running perhaps 12-14 v across battery.

What did you have running when the car went nuts, perhaps lights, or rear window demist, there might be something that either drags the voltage down or perhaps is corrupting the cars electrical supply.
 

·
Doktor Displacement
Joined
·
4,738 Posts
I will have to get a BMW diag done. In my infinite wisdom:) I decided I would save on the asking price and buy the 7er without a warranty to save a grand,wasn't that just the most amazing move!!!!! What figures am I looking for on the multi-meter and would I check it while running or shut-down?
Your battery should read around 12 volts when the car is switched off and around 14V when the car is running.

Its very unlikely that these problems are battery related. As if your battery is flat, the car would'nt start.
 

·
Bavaria Power!!!!!
Joined
·
566 Posts
Discussion Starter #9
I had lights,front fogs,heater and cd player going at both times. I'll get a multi-meter and see what that tells me and book a diagnostic with Kearys too!!!
 

·
Bavaria Power!!!!!
Joined
·
566 Posts
Discussion Starter #10
I just checked the battery and it had 11 volts when switched off and 13-14 running so the battery is good! The DSC fault has also disappeared???
 

·
You looking at me
Joined
·
492 Posts
Intermittent faults are a pain, chances are she will behave herself for a while

try switching each on item on in turn to try to get her to go nuts again, measure volts if you can.
Then try them all on. i suspect you'll need to drive her on a safe bit of road and start switching things on to get the fault
 
1 - 12 of 12 Posts
Top