BMW-Driver.net Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
Hey all,

A couple of friends have been using this site for a few years now and think very highly of it. So when I bought my first beemer this week they insisted that his would be my new home! :)

So, I bought a 645Ci last weekend from my boss and need some help with an outstanding issue (which in fairness he is going to pay for).

The car intermittently but frequently reports a Dynamic Drive failure, and subsequently errors about each of the following... Flat tyre sensor, Active steering failure, ABS and Control systems failure - Please drive moderately. I also notice that the handbrake and seatbelt warning lights come on intermittently and sometimes the speedo, screen and radio flicker.

We had the car in with a garage close to work (not a dealer) and they couldn't find the problem after 3 days. I google'd it and within seconds I found various posts with people suggesting that it could be the battery or alternator.

After reading that the alternator was making a whirring noise (while experiencing similar symptoms) on one forum, I actually heard the noise myself today, which leads me to believe that this is indeed the problem.

Next problem is that I'm in Wexford and work 9-5 Min-Fri in Dublin. I'm wondering does anyone know of a mechanic in the south east that could look at an alternator on a Saturday? It might be a bit much to ask for someone to fix it on such short notice but I'd love to at least come to a final diagnosis.

Any help is appreciated :eek:

On a lighter note, I'll make sure to get some pics up in the next couple of days!!

Kj
 

·
Ronin
Joined
·
8,708 Posts
Hey all,

A couple of friends have been using this site for a few years now and think very highly of it. So when I bought my first beemer this week they insisted that his would be my new home! :)

So, I bought a 645Ci last weekend from my boss and need some help with an outstanding issue (which in fairness he is going to pay for).

The car intermittently but frequently reports a Dynamic Drive failure, and subsequently errors about each of the following... Flat tyre sensor, Active steering failure, ABS and Control systems failure - Please drive moderately. I also notice that the handbrake and seatbelt warning lights come on intermittently and sometimes the speedo, screen and radio flickee






Davy b has a
We had the car in with a garage close to work (not a dealer) and they couldn't find the problem after 3 days. I google'd it and within seconds I found various posts with people suggesting that it could be the battery or alternator.

After reading that the alternator was making a whirring noise (while experiencing similar symptoms) on one forum, I actually heard the noise myself today, which leads me to believe that this is indeed the problem.

Next problem is that I'm in Wexford and work 9-5 Min-Fri in Dublin. I'm wondering does anyone know of a mechanic in the south east that could look at an alternator on a Saturday? It might be a bit much to ask for someone to fix it on such short notice but I'd love to at least come to a final diagnosis.

Any help is appreciated :eek:

On a lighter note, I'll make sure to get some pics up in the next couple of days!!

Kj
Davy b has a 6 he had a bit of hell with the rack, if you look up his thread in members section, hopefully it's not to bad. And welcome there is a couple of America s on the site
 

·
Registered
Joined
·
5,362 Posts
I seen this come up on a e60 before and the problem could not be traced.
The it turned out there was a buckle in a rear wheel which was causing a shuddered and bringing that message and light on.He got the 4 wheels ballanced and that was the end of that.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #9 ·
has the car been connected to diagnostics ? battery voltage checked ? mark murphys motors might be of some use to you there a site sponser and down your way
The garage near work had it connected to their diagnostics but I don't know how thorough that system is given they're not BMW specialists. They didn't find anything and said the car is fine. This was after 3 days in and out.

I went back the next morning showed it them with the errors on screen and they said it could be an ABS sensor. I suggested that it may be a battery/alternator issue having read about it but he dismissed the idea and said it'd be a few days before he could look at it again. I'm not keen on going back to them to be honest.

I assume from the dismissal of the battery/alternator idea that the battery wasn't even considered so I doubt the voltage was checked.
 

·
Registered
Joined
·
9,979 Posts
The garage near work had it connected to their diagnostics but I don't know how thorough that system is given they're not BMW specialists. They didn't find anything and said the car is fine. This was after 3 days in and out.

I went back the next morning showed it them with the errors on screen and they said it could be an ABS sensor. I suggested that it may be a battery/alternator issue having read about it but he dismissed the idea and said it'd be a few days before he could look at it again. I'm not keen on going back to them to be honest.

I assume from the dismissal of the battery/alternator idea that the battery wasn't even considered so I doubt the voltage was checked.
take the car to mark murphy motors or someone who knows them inside or out when my own battery was acting funny on the e39 it behaved totally different to other cars i had in the past it might not be the battery but the lads you dealt with sound like they lack the knowledge or just couldn't be arsed not good :(
 
1 - 11 of 11 Posts
Top